Notice

The material contained in this manual consists of information that is proprietary to JAI, Inc., and may only be used by the purchasers of the product. JAI, Inc. makes no warranty for the use of its product and assumes no responsibility for any errors which may appear or for damages resulting from the use of the information contained herein. JAI, Inc. reserves the right to make changes without notice.

Microsoft, Windows XP, Windows 2000, Windows 98, Windows NT, and Windows Explorer are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Warranty

Please contact your factory representative for details about the warranty.

Certifications

CE Compliance

The TS-9720/2030/2076/1327/4032 cameras have been certified to conform to the requirements of Council Directive 89/336/EC for electromagnetic compatibility and to comply with the following European Standards:


All JAI products bearing the CE mark have been declared to be in conformance with the applicable EEC Council Directives. However, certain factory-installed options or customer-requested modifications may compromise electromagnetic compatibility and affect CE compliance. Please note that the use of interconnect cables that are not properly grounded and shielded may affect CE compliance.

Contact JAI Applications Engineering Department for further information regarding CE compliance.

FCC

This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is operated in a commercial environment. This equipment generates, uses and can radiate radio frequency energy and, if not installed and used in accordance with the instruction manual, may cause harmful interference to radio communications. Operation of this equipment in a residential area may cause harmful interference, in which case the user will be required to correct the interference at his own expense.
WARNING
Changes or modifications to this unit not expressly approved by the party responsible for FCC compliance could void the user’s authority to operate the equipment.

JAI Inc.
625 River Oaks Parkway
San Jose, CA 95134
Tel:(408) 383-0300
Tel:(800) 445-5444
Fax:(408) 383-0301
E-mail: camerasales.americas@jai.com
www.jai.com

May 28, 2009
Table of Contents

Disclaimer Notice....................................................................................................... iii
Table of Contents ................................................................................................... v
List of Figures .......................................................................................................... vii
1 Document Overview ........................................................................................... 1
2 Installation and Operation .................................................................................... 2
  2.1 Installation ........................................................................................................ 2
  2.1.1 System Requirements .................................................................................. 2
  2.1.2 Locating the Software ................................................................................ 2
2.2 Login .................................................................................................................. 2
2.3 Network Adapter Setup ..................................................................................... 3
2.4 Main Window ..................................................................................................... 3
  2.4.1 Properties that hold the configuration part ............................................... 3
  2.4.2 Video Window where the image tools are found ....................................... 3
  2.4.3 File Menu Bar ............................................................................................ 3
  2.4.4 Tools Menu Bar ......................................................................................... 4
  2.4.5 Help Menu Bar ........................................................................................ 4
2.5 Camera Properties ............................................................................................ 4
  2.5.1 Camera Property Menus ............................................................................. 5
  2.5.2 Menu Bar Edit Commands ......................................................................... 7
  2.5.3 Tree view .................................................................................................... 7
  2.5.4 => Advanced Settings Sub Menus .............................................................. 9
  2.5.5 =>Refresh Properties (toggle function) .................................................... 11
  2.5.6 Property grid ............................................................................................. 11
2.6 Video Window .................................................................................................. 13
  2.6.1 Video Menu Menus .................................................................................. 14
  2.6.2 Edit Menu Menus ..................................................................................... 14
  2.6.3 View Menu Menus .................................................................................... 15
  2.6.4 Capture Menu Menus .............................................................................. 16
  2.6.5 Tree view .................................................................................................. 17
  2.6.6 Video Image ............................................................................................... 19
  2.6.7 Toolbar ..................................................................................................... 20
  2.6.8 Status Bar ................................................................................................ 27
  2.6.9 Focus Bar Waveform ................................................................................ 27
  2.6.10 Edit=>Copy ............................................................................................. 30
  2.6.11 Image Properties Window ........................................................................ 30
  2.6.12 Manual Exposure Window ....................................................................... 33
  2.6.13 Image Processing Window ....................................................................... 34
  2.6.14 Laser Setup Window ................................................................................ 34
2.7 Error Log Window ............................................................................................ 41
3 Configuration ........................................................................................................ 43
  3.1 User administration ....................................................................................... 43
  3.2 Firmware update ............................................................................................ 43
  3.3 Configure Storage Memory ........................................................................... 45
4 Appendix A: PC Minimum Specifications ............................................................ 46
  4.1 Software: ......................................................................................................... 46
  4.2 Hardware: ....................................................................................................... 46
5 Appendix B: Resolving IP-address problems ......................................................... 47
List of Figures

Figure 1. EN Setup Icon ............................................................................................................. 2
Figure 2. ENSetup Login ........................................................................................................... 2
Figure 3. EN Camera Setup Main Window ............................................................................... 3
Figure 4. EN Camera File Menu Bar Options .......................................................................... 3
Figure 5. Open Camera IP Address Dialog Box ..................................................................... 4
Figure 6. Tools Menu .............................................................................................................. 4
Figure 7. About Command ...................................................................................................... 4
Figure 8. Camera Properties Window ...................................................................................... 5
Figure 9. Camera Property File Menu ...................................................................................... 6
Figure 10. Page Setup Dialog Box. ........................................................................................ 6
Figure 11. A preview of the image being sent to the printer. .................................................... 7
Figure 12. Edit Commands ...................................................................................................... 7
Figure 13. Camera Property Tree View .................................................................................... 8
Figure 14. Camera Properties Context Menu .......................................................................... 9
Figure 15. Search for Cameras Message Box ......................................................................... 9
Figure 16. Advanced Settings Sub-Menu .............................................................................. 10
Figure 17. Camera Category Description .............................................................................. 11
Figure 18. Property Grid Shows Value Description ................................................................ 12
Figure 19. Property Description in the Bottom of the Window ............................................... 12
Figure 20. Editing the Value Field ........................................................................................ 12
Figure 21. Editing a Checked List ........................................................................................ 13
Figure 22. Editing the Value Field ........................................................................................ 13
Figure 23. The Video Window ............................................................................................... 13
Figure 24. Video Window File Menu Bar ............................................................................... 14
Figure 25. Video Window Edit Menu Bar .............................................................................. 14
Figure 26. Video Window File Menu Bar .............................................................................. 15
Figure 27. Video Window Capture Menu Bar ......................................................................... 16
Figure 28. Filename Example 1: .......................................................................................... 16
Figure 29. Filename Example 2: .......................................................................................... 16
Figure 30. Filename Example 3: .......................................................................................... 17
Figure 31. Select Encoder Menu .......................................................................................... 17
Figure 32. Video Window Tree View Menus .......................................................................... 18
Figure 33. Video Window Context Menus ............................................................................ 19
Figure 34. Tool Bar ............................................................................................................... 20
Figure 35. Display Modes ...................................................................................................... 21
Figure 36. Setup Tools Menu ................................................................................................ 22
Figure 37. Camera Roll Bar ................................................................................................... 22
Figure 38. Camera Tilt Line .................................................................................................. 23
Figure 39. Camera Focus Bar ................................................................................................ 24
Figure 40. Measuring Box ..................................................................................................... 25
Figure 41. Trigger Modes ...................................................................................................... 25
Figure 42. Select Menus from the Content Window ............................................................... 26
Figure 43. Video Window Settings Dialog Box ..................................................................... 27
Figure 44. Status Bar displays the Pixel values ..................................................................... 27
Figure 45. Focus Bar Waveform Screen .............................................................................. 28
Figure 46. Focus Bar Waveform Menus ............................................................................... 29
Figure 47. Waveform Screen Commands .............................................................................. 30
Figure 48. Image Properties Context Menu .......................................................................... 31
Figure 49. Image Properties with the TCP/IP option selected ............................................... 32
Figure 50. Manual Exposure Window ................................................................................... 33
Figure 51. Image Processing Context Menu ......................................................................... 34
Figure 52. Vehicle Detector Settings .................................................................................... 35
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>53</td>
<td>Laser Vehicle Collect Data button</td>
<td>36</td>
</tr>
<tr>
<td>54</td>
<td>Laser Setup Wizard Start screen</td>
<td>37</td>
</tr>
<tr>
<td>55</td>
<td>Laser Wizard data collection</td>
<td>37</td>
</tr>
<tr>
<td>56</td>
<td>Successful data collection</td>
<td>38</td>
</tr>
<tr>
<td>57</td>
<td>Wizard with Offset Values</td>
<td>38</td>
</tr>
<tr>
<td>58</td>
<td>Wizard Filter Size Dialog Box</td>
<td>39</td>
</tr>
<tr>
<td>59</td>
<td>Hysteresis Count</td>
<td>39</td>
</tr>
<tr>
<td>60</td>
<td>Trigger Output Polarity</td>
<td>40</td>
</tr>
<tr>
<td>61</td>
<td>Laser Setup Wizard Finish Window</td>
<td>41</td>
</tr>
<tr>
<td>62</td>
<td>Error Log Window</td>
<td>41</td>
</tr>
<tr>
<td>63</td>
<td>Close-up of an Error Log Context Menu</td>
<td>42</td>
</tr>
<tr>
<td>64</td>
<td>User Administration Window</td>
<td>43</td>
</tr>
<tr>
<td>65</td>
<td>User Credentials Dialog</td>
<td>43</td>
</tr>
<tr>
<td>66</td>
<td>Firmware Update</td>
<td>44</td>
</tr>
<tr>
<td>67</td>
<td>Firmware Update</td>
<td>44</td>
</tr>
<tr>
<td>68</td>
<td>Files Drop-down list</td>
<td>45</td>
</tr>
<tr>
<td>69</td>
<td>Internal Storage Settings</td>
<td>45</td>
</tr>
<tr>
<td>70</td>
<td>IP Address Conflict Window</td>
<td>47</td>
</tr>
<tr>
<td>71</td>
<td>Set New IP Address Window</td>
<td>47</td>
</tr>
</tbody>
</table>
Vehicle Imaging System EN Setup Software

1 Document Overview
This document describes the EN Setup program for the VISCAM Vehicle Imaging System.

The EN Setup Program is used for configuring, adjusting and aligning the cameras as well as viewing and analyzing the images.

Tools are found for adjusting zoom and focus and aligning roll and tilt.

Images can be viewed, saved and printed. Images can be transferred to other applications.

The EN Setup program is used when installing and setting up the cameras. It can be used for maintenance monitoring and troubleshooting.

The EN Setup program is used together with the VISCAM Installation Manual where the practical installation details are found. In this manual is also found the actual parameters to be set up.

EN Camera details are found in the EN Camera documentation.

Terminology:
“PC" is the device on which the application is run.
“Primary mouse button” is the left button for right-hand mouse set-up.
“Secondary mouse button” is the right button for right-hand mouse set-up.
2 Installation and Operation

2.1 Installation
To install the program follow the EN Setup Install Shield Wizard. The install program adds a shortcut to the desktop and in the “Start->All Program” menu.

2.1.1 System Requirements
- Windows XP installed with Service Pack 2
- Microsoft .NET Framework 2.0

Note: Microsoft .NET Framework 2.0 installation is required prior to ENSetup software installation. The .NET Framework software is available on the JAI software download site. Please visit www.jai.com. Click Traffic Solutions and select the SOFTWARE button on the left menu icons.

- The host PC must have at least a 1.8 GHz processor, and 512 MB of RAM

2.1.2 Locating the Software
You will need to install Microsoft .NET Framework 2.0 prior to ENSetup installation. See section 2.1.1. Go to www.jai.com. Click Traffic Solutions and select the SOFTWARE button on the left menu. Find the ENSetup software.

Double clicking on the EN Setup icon starts the application

Figure 1. EN Setup Icon

2.2 Login
The program is protected by a login screen that asks for the User name and Password.

Figure 2. ENSetup Login

At the first login the User name is default set to “Administrator” and the Password is “Password”. This is filled in automatically only the first time. Please change the password or add users.

The last User name is automatically filled in the next time the program is started.

Tip If the password is removed for the last selected user, then ENSetup will startup without displaying the Login Dialog. By holding the Shift key down during startup, the Login dialog will be forced to be displayed anyhow so the current user can be changed!

There are three user levels: Restricted user, Supervisor and Administrator. Adding users and user levels are described in section 3.1.
2.3 Network Adapter Setup
After successful login ENSetup automatically searches for cameras connected to all network adapters on the PC. If any IP-address problems are detected then a window will be displayed and it will be possible to correct these problems (see appendix B for a description on how to correct IP-address problems).

Figure 3. EN Camera Setup Main Window

Note: The EN detection process does not locate Cameras that are not part of the local subnet. Use the Open Camera, or Open Cameras option to connect to cameras outside of the local subnet. (See section 2.4.3 for more information.)

2.4 Main Window
The EN Camera Setup program has two sections:

2.4.1 Properties that hold the configuration part
2.4.2 Video Window where the image tools are found
Each section is selected by clicking the associated bar in the opening window shown in Figure 3.

Tip By holding the shift key down when Properties or Video Window is activated, the windows are opened in default size and position.

2.4.3 File Menu Bar
Figure 4. EN Camera File Menu Bar Options

2.4.3.1 File=>Open Camera
This command opens a specific camera by specifying an IP-address. This option is useful if the camera is not on a local subnet and therefore not found automatically during a search (Section 2.3 above). This will open an “Open Camera” dialog where the IP-address can be typed in.
2.4.3.2 File=>Open Camera List
This command opens a list of IP-addresses. This option is useful, if the camera is not on a local subnet and therefore not found automatically during a search (Section 2.3 on page 3)

2.4.3.3 File=>Save Camera List
This command saves the current list of cameras to a file that can be retrieved later.

2.4.3.4 File=>Exit
The Exit command exits the program

2.4.4 Tools Menu Bar

2.4.4.1 Tools=>User Administration
The User Administration command updates the list of users (see section 3.1 for details)

2.4.4.2 View Error Log
The View Error Log command opens a new window where all errors and information messages from the cameras and ENSetup are shown (see section 2.5 for details)

2.4.5 Help Menu Bar

2.4.5.1 About
The About command shows the program version and a link to an Internet site where the latest version of the program can be downloaded.

2.5 Camera Properties
The Camera Properties window is shown in Figure 8 on page 5.
The left side of the window shows a tree view of the cameras found (see section 2.3). The right side of the window shows a property-grid of the configuration parameters. The window is closed by clicking the Windows Close button and opened using the Properties bar.

Figure 8. Camera Properties Window

2.5.1 Camera Property Menus

Using the commands on the File menu the camera properties can be imported or exported from or to files, or printed out.
2.5.1.1 File=>Import Settings from File to Camera
The Import Settings from File to Camera command opens a file-open dialog box for selecting the camera-settings file to import into the selected camera. This feature will set up all camera properties including camera-specific settings like the static IP-address and User Information so it will for instance be used for “Restoring” the settings from file to a new camera if the camera hardware has been replaced. If only the “System specific” settings need to be setup then please use the Edit Copy Settings from Camera and Edit Paste Settings to Camera(s) instead!

2.5.1.2 File=>Export Settings from Camera(s) to File(s)
The Export Settings from Camera(s) to File(s) command opens a file-save dialog box for selecting the names of the camera-settings files to save. Default filenames will be generated automatically based on camera IP-address and date/time. This feature will “Backup” all camera properties including camera specific settings like the static IP-address and User Information so it can be used for “Restoring” the settings from file to a new camera if the camera hardware has been replaced.

2.5.1.3 File=>Page Setup
The Page Setup command opens a dialog box for selecting paper format.
2.5.1.4  File=&gt;Print Preview shows the print on the screen before printing

Figure 11. A preview of the image being sent to the printer.

2.5.1.5  File=&gt;Print sends the print job to the printer

2.5.1.6  File=&gt;Exit exits the program.

2.5.2  Menu Bar Edit Commands

Figure 12. Edit Commands

2.5.2.1  Edit=&gt;Copy Settings from Camera
This command will copy the current settings from the selected camera into memory so it later on can be pasted into other cameras. This makes it very easy to copy system specific settings from one camera to many other cameras. These settings do not include camera-specific settings such as Static IP-address and User Information but only the system-specific information.

2.5.2.2  Edit=&gt;Paste Settings to Camera(s)
This command will paste the previously copied system-specific settings to one or more cameras selected. This makes it very easy to copy system specific settings from one camera to many other cameras. These settings do not include camera-specific settings such as Static IP-address and User Information but only the system-specific information.

2.5.3  Tree view
The cameras in the tree view are identified by their IP and MAC addresses. Color cameras are identified with the small “Rainbow” icon behind the camera icon.
The property-grid shows the properties for the camera selected. The camera is selected by clicking the primary mouse button on the camera icon or label.

More cameras can be selected at the same time by holding the Ctrl-key activated while clicking the primary mouse button while pointing on the cameras. When more cameras are selected the property grid shows the properties that are equal for the cameras. Properties that are not equal are left blank.

Properties can also easily be set to the same value for more cameras this way.

Figure 13. Camera Property Tree View

2.5.3.1 Context menus

Right-side clicking the mouse on the camera-tree side of the CAMERA PROPERTIES window activates the context menus.

The menu is shown in Figure 14 and applies for the camera(s) selected.
2.5.3.2 \Rightarrow \textbf{Search for Cameras}

This command starts a new search for cameras on the local network. The message box below is shown when ENSetup opens the connections.

\begin{figure}
\centering
\includegraphics[width=\textwidth]{search_for_cameras}
\caption{Search for Cameras Message Box}
\end{figure}

If any IP-address problems are detected then a window will be displayed and it will be possible to correct these problems (see appendix C for description on how to correct IP-address problems).

2.5.3.3 \Rightarrow \textbf{Open Cameras}

This command opens a specific camera by specifying an IP-address. This can be used, if the camera is not on a local subnet and therefore not found automatically during a search (Section 2.3 on page 3 or Section 2.4 on page 3).

2.5.4 \Rightarrow \textbf{Advanced Settings Sub Menus}

This command opens up a sub-menu with all available advanced settings.
2.5.4.1 ➔ Advanced Settings ➔ Save/Restore Settings inside Camera(s) ➔ Save Settings into Flash Memory
This command saves the current setting in the camera as shown by EN Setup into the cameras flash memory. The camera will then start up with these settings next time it reboots.

2.5.4.2 ➔ Advanced Settings ➔ Save/Restore Settings inside Camera(s) ➔ Restore Settings from Flash Memory
This command loads the settings from the cameras flash memory into the current setting of the camera. This can be used for restoring settings from last time it was saved in the camera and thereby ignoring changes that have been made since then.

2.5.4.3 ➔ Advanced Settings ➔ Export Settings from Camera(s) to File(s)
This command opens a file-save dialog box for selecting the names of the camera-settings files to save. Default filenames will be generated automatically based on camera IP-address and date/time. This feature will “Backup” all camera properties including camera-specific settings like the static IP-address and User Information so it can be used for “Restoring” the settings from file to a new camera if the camera hardware has been replaced.

2.5.4.4 ➔ Advanced Settings ➔ Import Settings from File to Camera
This command opens a file-open dialog box for selecting the camera-settings file to import into the selected camera. This feature will setup all camera properties including camera-specific settings like the static IP-address and User Information so it will for instance be used for “Restoring” the settings from file to a new camera if the camera hardware has been replaced. If only the “System specific” settings need to be setup then please use the Advanced Settings ➔ Copy Settings from Camera and Advanced Settings ➔ Paste Settings to Camera(s) instead!

2.5.4.5 ➔ Advanced Settings ➔ Copy Settings from Camera
This command will copy the current settings from the selected camera into PC memory so it later on can be pasted into other cameras. This makes it very easy to copy system specific settings from one camera to many other cameras. These settings do not include camera-specific settings such as Static IP-address and User Information but only the system-specific information.

2.5.4.6 ➔ Advanced Settings ➔ Paste Settings to Camera(s)
This command will paste the previously copied system-specific settings to one or more cameras selected. This makes it very easy to copy system specific settings from one camera to many other cameras. These settings do not include camera-specific settings such as Static IP-address and User Information but only the system-specific information.
2.5.4.7  =>Advanced Settings=>Update Firmware in Camera(s)
This command opens a new dialog box for uploading firmware to the cameras. See Section 3.2 on page 43 for details.

2.5.4.8  =>Advanced Settings=>Reboot Camera(s)
This command reboots the camera(s) selected

2.5.4.9  =>Advanced Settings=>Configure Storage Memory in Camera
This command opens a new dialog box where the internal image queue settings can be modified. See section 3.3 for details.

2.5.4.10 =>Advanced Settings=>Telnet Camera(s)
This command opens a new window with a telnet session for each selected camera.

2.5.4.11 =>Advanced Settings=>Time synch from PC to Camera (temporary function)
This command sends the UTC-time from the PC’s internal clock to the camera(s) selected.

2.5.5  =>Refresh Properties (toggle function)
This command reads the values from the camera(s) every second. Stops reading when toggled off or if a property value from the property list is selected.

2.5.6  Property grid
The listings in the property grid of the CAMERA PROPERTIES can be shown in alphabetic order or categorized in 9 categories as shown in Figure 17 below.

Each category can be expanded by clicking on the “+” in front of the category number and compressed by activating the “-“.

When a category is selected a description is shown in the bottom of the window.

Figure 17.  Camera Category Description

When a category is maximized the values are shown as in Figure 18 on page 12. Some values can be setup by the user and some are read-only (indicated by grey color text)
When a property is selected a description is shown in the bottom of the window (Figure 19).

**Figure 19. Property Description in the Bottom of the Window**

Editing the value field can be done via a drop list as shown in Figure 20. Clicking the primary mouse button on the value field activates the drop list and the function can be chosen from the list.

**Figure 20. Editing the Value Field**

The drop list can also be a checked drop list as shown in Figure 21 on page 13.
Figure 21. Editing a Checked List

![Image of a checked list]

The value field can be filled in by the user as shown for the IP Address in Figure 22.

Figure 22. Editing the Value Field

![Image of a value field]

2.6 Video Window

The VIDEO WINDOW is shown in Figure 23.

The left side of the window shows a tree-view of the cameras found (Section 2.3 on page 3 and Section 2.4 on page 3).

The right side of the window is the video image.

In the top of the window is a toolbar with commands and in the bottom of the window is a status line.

The window is closed by clicking the red X in the upper right corner and is opened again by clicking the Video Window bar in the EN CAMERA SETUP dialog box.

Figure 23. The Video Window
2.6.1 Video Menu Menus

Figure 24. Video Window File Menu Bar

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>View</th>
<th>Capture</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open…</td>
<td></td>
<td></td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Save As…</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page Setup</td>
<td>Print Preview</td>
<td>Print…</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Exit</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2.6.1.1 File=>Open…
This command opens a file in the VIDEO WINDOW. This can be used for analyzing saved images. The value for some of the image tags will be displayed on-screen when the files are opened.

*TIP Using drag-and-drop from e.g., Explorer, can also open images. It is possible to easily browse between the selected images using the arrow-keys or the mouse scroll button. It is furthermore possible to see the image properties of the images.*

2.6.1.2 File=>Save As…
This command saves the image shown in the VIDEO WINDOW to a file. The format of the image saved can be selected from a drop list (JPEG, TIFF, PNG, BMP and GIF)

2.6.1.3 File=>Page Setup
This command opens a dialog box for setting up paper format (Figure 10 on page 6)

2.6.1.4 File=>Print Preview
This command shows the print on the screen before printing. The video image and activated tools are printed.

2.6.1.5 File=>Print…
This command prints out the VIDEO WINDOW and activated tools (see section 3.1) to the default printer.

2.6.1.6 File=>Exit
This command exits the program

2.6.2 Edit Menu Menus

Figure 25. Video Window Edit Menu Bar

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>View</th>
<th>Capture</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td></td>
<td></td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td></td>
<td></td>
<td>Ctrl+V</td>
</tr>
</tbody>
</table>

2.6.2.1 Edit=>Copy
This command copies the image in the VIDEO WINDOW to the clipboard for pasting to other programs (Word, Paint etc.)

2.6.2.2 Edit=>Paste
This command inserts the image from the clipboard to the VIDEO WINDOW
TIP Using drag-and-drop from e.g., Explorer, can also open images.

### 2.6.3 View Menu Menus

**Figure 26. Video Window File Menu Bar**

#### 2.6.3.1 View=>Full Size/Half Size/Quad Size
This command selects the display mode. See Section 2.6.7 on page 20 for a full description.

#### 2.6.3.2 View=>Roll Bar/Tilt Line/Focus Bar/Measuring Box
This command selects the setup tools. See Section 2.6.7 on page 20 for a full description.

#### 2.6.3.3 View=>Image Properties
This command opens a new window that displays the image properties for the image displayed in the Video Window. See Section 2.6.11 on page 30 for a full description of the Image Properties Window.

#### 2.6.3.4 View=>Use TCP/IP
This command selects if the images are transferred from the camera to the ENSetup using both TCP/IP and UDP/IP (default on test channel) or only UDP/IP on the test channel. The images transferred using TCP/IP are “real” images identical to the ones any Lane Controller would receive. They are ONLY generated based on “real” triggers (TTL, Ethernet and RS-485) - NOT the images generated in the “Snap” and “Live” trigger modes! These images are tagged with all available information inside the EN-cameras opposed to the test channel images transferred using UDP/IP. These test channel images are ONLY tagged on the PC-side and will not contain information regarding the camera settings etc.

#### 2.6.3.5 View=>Color Interpolate
This command selects if the color interpolation will be performed on images from the Color EN cameras. If this is deselected the “raw” images will be displayed instead of color images.

#### 2.6.3.6 View=>Image Processing
This command opens a new window that displays the image processing tools for the image displayed in the Video Window. By using this Image Processing it is possible to adjust the Gamma-correction, Brightness, Contrast and Saturation on the displayed images. This will not change the images saved using ENSetup but the Image Processing can also be activated on the images printed out using the File Print…menu. See Section 2.6.13 on page 34 for a full description of the Image Processing Window.
2.6.4 Capture Menu Menus

Figure 27. Video Window Capture Menu Bar

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>View</th>
<th>Capture</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td><img src="image" alt="Capture Menu Bar" /></td>
</tr>
</tbody>
</table>

2.6.4.1 Capture=>Capture Images (toggle function)
This command starts or stops saving images to the hard disk.
Be careful: This can generate a lot of data to the hard disk. The images are tagged with the IP Address and the UTC time from when the image was taken plus the type of image.

Figure 28. Filename Example 1:

![Filename Example 1](image)

Explanation:
1. Camera IP address: 10.0.0.101
2. Image capture date: May 31, 2006
3. Timestamp (UTC) 10:56:34.897
4. TST (test) image captured from the “test-channel” (UDP transfer between camera and PC)
5. JPEG compressed image

Note: The image tags are generated inside ENSetup!

Figure 29. Filename Example 2:

![Filename Example 2](image)

Explanation:
1. IP address of the camera: 10.0.0.101
2. Date image was captured: May 31st, 2006
3. Timestamp (UTC) 10:56:34.897
4. Second image in sequence
5. “ORG” (original - but converted) image captured from the camera (TCP transfer between camera and PC). The image tags are generated inside the camera and therefore contain information such as error status, Light Sensor readings, exposure settings, NTP status and other important data from the time of the image capture inside the camera. When images are saved the selected Image Encoder will be used. So if the camera for instance generates TIFF images, then ENSetup is capable of saving the images in for instance JPEG format.
6. JPEG compressed image
Figure 30. Filename Example 3:

\[
\begin{array}{ccccccc}
1 & 2 & 3 & 4 & 5 & 6 \\
10.0.0.101 & 2006-05-31 & 10-56-34-897 & 1 & _{\text{RAW}.\text{TIF}}
\end{array}
\]

Explanation:
1. IP address of the camera: 10.0.0.101
2. Date image was captured: May 31st, 2006
3. Timestamp (UTC) 10:56:34.897
4. First image in sequence
5. RAW image captured from the camera (TCP transfer between camera and PC). The image tags are generated inside the camera and therefore contain information such as error status, Light Sensor readings, exposure settings, NTP status and other important data from the time of the image capture inside the camera.
6. Uncompressed TIFF image (directly transferred from the camera)

**Note:** Images received from the camera using TCP/IP are saved directly without any modifications!

The Caption of the Video Window will flash every second with the text Video Window - Capturing Images! as long as the Image Capture is active.

2.6.4.2 Capture=>Capture folder …
This command selects the folder to where the captured images are saved

2.6.4.3 Capture=>Select Image Encoder
This command selects which encoder to be used when captured images are saved. The format of the image saved can be selected from a popup window drop list (Built in JPEG, TIFF, PNG, BMP and GIF).

Figure 31. Select Encoder Menu

![Select Encoder Menu](image)

2.6.4.4 Capture=>Save Images in RAW format (toggle function)
This command selects if the images received from the camera using TCP/IP should be saved directly without any modifications. When this option is enabled, the View Use TCP/IP option will be automatically enabled too (see description of the View menu above).

2.6.5 Tree view
The cameras in the tree view are identified only by their IP addresses.
The Video Window shows the image from the camera selected.

2.6.5.1 Context menus
Clicking the secondary mouse button on the camera-tree side of the VIDEO WINDOW activates the context menu. See Figure 32 on page 18.
2.6.5.2  =>Search for cameras
This command starts a new search for cameras on the local network.

The OPENING NEW CAMERAS message box (see Figure 15 on page 9) is shown while searching for cameras
If any IP-address problems are detected then a window will be displayed and it will be possible to correct these problems (see appendix B for a description on how to correct IP-address problems).

2.6.5.3  =>Open Camera
This command opens a specific camera by specifying an IP-address. This can be used, if the camera is not on a local subnet and therefore not found automatically during a search (search: see Section 2.3 on page 3 or Section 2.4 on page 3). This will open an Open Camera dialog where the IP-address can be typed in (see Section 2.3 on page 3).

2.6.5.4  =>Manual Exposure
This command opens a new window where the Camera Exposure (Shutter, Gain, Pedestal, VTop/ VBottom and Gamma) can be controlled manually. See Section 2.6.12 on page 33 for a full description of the Manual Exposure Window. This is typically used when adjusting the cameras in low light conditions during installation/adjustment at the roadside in the night.

2.6.5.5  =>Laser Setup
This command opens a new window where a serially connected Laser Trigger can be Setup. See Section 2.6.14 on page 34 for a full description of the Laser Setup Window. This is typically used when adjusting and testing the internal trigger setting of the Laser Trigger.

2.6.5.6  =>Image Processing
This command opens a new window that displays the image processing tools for the image displayed in the Video Window. Using this Image Processing it is possible to adjust the Gamma-correction, Brightness, Contrast and Saturation on the displayed images. This will not change the images saved using ENSetup but the Image Processing can also be activated on the images printed out using the File Print...menu. See Section 2.6.13 on page 34 for a full description of the Image Processing Window.
2.6.6 Video Image
This is the area where the actual images are displayed. The video image shows the images sent from the cameras labeled with IP Address and UTC time in the upper left corner.

Tip
A frame-counter can be displayed/hidden by pressing CTRL+F when the video image is in focus.

2.6.6.1 Context menus
Right-side clicking the mouse on the Video Image side of the VIDEO WINDOW activates the context menu. See Figure 14 on page 9.

Figure 33. Video Window Context Menus

2.6.6.2 ➔Unselect Camera
This command clears the current camera selection and blanks the Video Image display.

2.6.6.3 ➔View Image Properties
This command opens a new window that displays the image properties for the image displayed in the Video Window. See Section 2.6.11 on page 30 for a full description of the Image Properties Window.

2.6.6.4 ➔Manual Exposure
This command opens a new window where the Camera Exposure (Shutter, Gain, Pedestal, VTop/ VBottom and Gamma) can be controlled manually. See Section 2.6.12 on page 33 for a full description of the Manual Exposure Window. This is typically used when adjusting the cameras in low light conditions during installation/adjustment at the roadside in the night.

2.6.6.5 ➔Laser Setup
This command opens a new window where a serially connected Laser Trigger can be Setup. See Section 2.6.14 on page 34 for a full description of the Laser Setup Window. This is typically used when adjusting and testing the internal trigger setting of the Laser Trigger.

2.6.6.6 ➔Image Processing
This command opens a new window that displays the image processing tools for the image displayed in the Video Window. Using this Image Processing it is possible to adjust the Gamma-correction, Brightness, Contrast and Saturation on the displayed images. This will not change the images saved using ENSetup but the Image Processing can also be activated on the images printed out using the File Print... menu. See Section 2.6.13 on page 34 for a full description of the Image Processing Window.
2.6.6.7 Zoom Video Image

It is possible to zoom in on the images displayed by dragging an area using the middle mouse-button or Alt-key plus primary mouse button. To maintain the aspect-ratio of the original image the Ctrl-key on the keyboard has to be depressed during the dragging of the zoom-area. If the Shift-key is depressed instead during the dragging of the zoom-area the zoom area will be a square box.

It is possible to continue zooming in the already zoomed image!

To get back to the original image simply click the middle mouse-button or Alt-key plus primary mouse button once inside the video image area.

Tip The numeric keyboard (in the small section beside the main keyboard) can be used to zoom as well! By pressing the + and - buttons the zoom level will be changed. By pressing the 1- to 9-keys the area will be moved around in the direction of the key. The 7-key will for instance move the area up and to the left. By pressing the 5-key the zoom will be canceled and the original image will be displayed again. To increase the zoom and move operations press and hold the Shift-key. If you press and hold the Ctrl key combined with one of the numeric keys, the zoom and location shifting become faster.

2.6.7 Toolbar

The toolbar is located in top of the VIDEO WINDOW and has buttons for selecting

- Display modes
- Setup tools
- Trigger modes
- Settings

Figure 34. Tool Bar

2.6.7.1 Display Modes

There are three display modes for the video image selectable from the left side of the tool-bar (see Figure 34):

- Full Size: maximum resolution (W x H)
- Half Size: Half images from up to two cameras simultaneously (W/2 x H)
- Quad Size: Quarter images from up to four cameras simultaneously (W/2 x H/2)
The various display modes remember the trigger mode that was selected when they were displayed. If Live was selected for a camera in Full Size view, Last was selected in Half Size and Snap was selected for Quad Size, the same trigger modes are active when the various display modes are selected. (Trigger modes see Section 2.6.7 (on page 20)

In Half Size and Quad Size display modes the active half or quarter of the video image (cameo) is indicated by a red dot in upper left corner. The active part is selected by clicking the mouse on the part.

The signal to be displayed in the active part of the image window is selected by clicking on the camera in the camera tree in the left side of the Video Window.

- The video image is blue if no camera has been selected to be displayed.
- The video image is also blue if an image has not been received from the selected camera.

The cameras can also be “dragged and dropped” from the tree-view to any of the view positions to select the camera.

2.6.7.2 Setup Tools
The setup tools are activated and deactivated by toggling the function in the toolbar. Each tool inserts lines or a box in the image easing the alignment and adjustment of the camera.
The setup tools can be configured using the Settings Dialog, see section 2.4.3.9.

Roll Bar

The Roll Bar is used when adjusting the camera “roll”. A horizontal line with a small vertical center line is inserted as shown in Figure 37. This must e.g. be in line with the bumper on the car.

The line can be positioned vertically by pointing the mouse on the line and holding the left-side button down and then move it to the wanted position. The line is only moved vertically - the center marking stays in the center of the line.

The line can also be positioned by dragging a box around a part of the line using the mouse while holding the primary mouse button down. The line will then change color and the up and down arrows can then be used for positioning the line.

See VISCAM Installation Manual for details regarding camera adjustment.
Tilt Line
The Tilt Line inserts a horizontal line with two vertical zoom-markers. The camera zoom is adjusted until the license plate is displayed with the same width as the distance between the markers.

The line can be positioned vertically using the mouse or arrows as described for the Roll Bar and the zoom markers can be positioned anywhere along the line.

See VISCAM Installation Manual for details regarding camera adjustment.

Figure 38. Camera Tilt Line

Focus Bar
The Focus Bar is a horizontal line with same length as the distance between the Focus Marks on the Tilt Line. The line can be positioned as described under Roll Bar.

When the Focus Bar is activated a FOCUS BAR WAVEFORM window is opened showing the pixel values along the Focus Bar. This is used for focus adjusting the camera.

See VISCAM Installation Manual for details regarding camera adjustment.

The FOCUS BAR WAVEFORM window is described in details in Section 2.6.9 on page 27
Figure 39. Camera Focus Bar.

Measuring Box

The Measuring Box is used to measure the dimension of e.g. the license plate. The box position, height and width are shown in the status bar in the bottom of the image.

The size of the box can be adjusted by dragging the corner markings of the box using the mouse and dragging the center marks on the box sides can change the position.

Dragging a box around the measuring box with the mouse or clicking on the box line can select the box. The box color will then change.

The box can then be moved using arrow-up and arrow-down keys. The height of the box can be adjusted holding the shift-key down and using arrow-up (bigger height) and arrow-down keys (lower height) and the width can be adjusted using the shift-key and arrow-left (bigger width) and arrow-right (smaller width).
2.6.7.3 Trigger Modes

Trigger modes can be selected using the Tool bar as shown in Figure 41 or by right-side clicking the mouse in the image window activating the context menu as shown in Figure 42.

![Figure 41. Trigger Modes](image)

Via the context menu the camera can furthermore be unselected.

![Matching Box data](image)
Available trigger modes are:

1. **Freeze**
   - No more images are transmitted (disable trigger)

2. **Snap**
   - One image is transferred

3. **Live**
   - Images are transferred as fast as the camera can transmit and the PC can receive

4. **One**
   - The current image is deleted and when the next hardware triggered image is received it will be shown

5. **All**
   - The current image will be deleted and all subsequent hardware triggered images will be shown

6. **Last**
   - The last hardware triggered image in the camera will be shown and internal trigger mode will then change to All

The default trigger mode is **Last** and the latest UTC labeled image can always be transferred from the camera.

It is possible to generate “hardware” triggers via the Ethernet by activating **Eth Trig** in the Tool bar or **Rep Trig** (toggle functions).

**Eth Trig** generates one Ethernet trigger pulse and **Rep Trig** default generates one trigger pulse every second. If **Rep Trig** is selected and then **Eth Trig**, one final trigger pulse will be generated and the repetitive trigger will be stopped. The speed of the Repetitive Trigger can be adjusted using the Video Window Settings dialog described in Section 2.6.7.

### 2.6.7.4 Settings Dialog

The **VIDEO WINDOW SETTINGS** is activated from the **Settings** in the Tools Bar and holds the property page for configuration of tools in the Tools Bar and titles in the Image Window.

The setup can be saved using the **Save as Custom** button and retrieved using the **Load Custom** button.

The factory settings can be loaded using the **Load Factory** button.

Changes made are applied via the **Apply** and **Exit** button.

If changes are not to be applied clicking the cross in the upper right corner leaves the dialog box.
2.6.8 Status Bar

The Status Bar shows tool values. The actual pixel values will be displayed in the status bar when the mouse cursor is placed over the image. If it is a Color camera each of the RGB values will be displayed.

Figure 44. Status Bar displays the Pixel values

The VIDEO WINDOW SETTINGS dialog is opened when clicking the mouse inside the Status Bar.

2.6.9 Focus Bar Waveform

The FOCUS BAR WAVEFORM window is opened when the Focus Bar is selected in the Toolbar. It can be used for adjusting the camera focus or analyzing images.
The actual pixel values along the focus bar are shown in the graph. If the focus bar is positioned across the license plate (see Figure 39 on page 24) the pixel values will reflect the grey levels of the characters and the spacing.

A high pixel level belongs to a white image element and a low pixel value belongs to a black image element.

When the amplitude of the graph is at a maximum then the camera is focused correctly.

The “White Level Cursor” and the “Black Level Cursor” can manually be dragged and positioned using the mouse and the according levels are shown in the status bar in the button of the window. These are marked Black Cur and White Cur. The distance between the two cursors is listed after Diff.

The two white dashed lines indicate the average level of the white pixels (the upper) and the average level of the black pixels (the lower). These two levels are updated dynamically and are used for calculating a relative focus value that is shown in the red column in the left side. The maximum relative focus value obtained will be displayed as shown in Figure 45 as a Max Level indicator line. Double clicking the primary mouse button inside the column will reset the max level indicator.

The column height can vary between 0 and 100%.
Figure 46. Focus Bar Waveform Menus

2.6.9.1 File=>Save As
This command saves the graph to a file. The format of the image saved can be selected from a drop list (JPEG, TIFF, PNG, BMP and GIF)

2.6.9.2 File=>Page Setup
This command opens a dialog box for setting up paper format (see Figure 10 on page 6)

2.6.9.3 File=>Print Preview
This command shows the print on the screen before printing.

2.6.9.4 File=>Print…
This command prints out the graph and the status line information to the default printer
Figure 47. Waveform Screen Commands.

2.6.10 Edit=>Copy
This command copies the Graph to the clipboard for pasting to other programs (Word, Paint etc.)

2.6.11 Image Properties Window
All images displayed and captured using ENSetup contains a number of image properties embedded inside each image. All these image properties are placed in the image files as EXIF-tags.

To view the image tags associated with the selected image displayed in the Video Window simply select the View Image Properties menu in the Video Window or the View Image Properties context menu in the Video Window. This opens a new window that displays the image properties for the image displayed in the Video Window. The contents will be update for every new image.

The amount of data available varies depending on the ENSetup settings selected.

The default image format used by ENSetup on the “test-channel” only contains the raw pixel data and additional timestamp information. The rest of the information is generated in ENSetup and NOT in the camera (ImageDescription="ENSetup Generated").

See Figure 48 for an example of the test channel image information.
If the “Use TCP/IP” option is selected (see Section 2.6.3 on page 15) the ENSetup will request images from the camera using the TCP/IP LC-protocol.
Figure 49. Image Properties with the TCP/IP option selected

The image tags are generated inside the camera and therefore contain information such as status, Light Sensor readings, exposure settings, NTP status and other important data from the time of the image capture inside the camera. All ITS-specific information is placed in the “ITS Camera Tags” category.
2.6.12 Manual Exposure Window

Normally camera parameters are optimally controlled by the light sensor, and it is not necessary to manipulate them manually. However, during installation and adjustment of the cameras at nighttime it is often necessary to manually adjust the shutter and gain values of the cameras in order to make the camera sensitive enough to produce usable images. This will temporarily disable the Light Sensor exposure control (ADR) inside the camera and force the camera to use manual exposure values instead.

Do not change these parameters, unless you know exactly what you want to do. To use the Manual Exposure simply select the Manual Exposure context menu in the Video Window. This opens a new window that enables direct control of the camera.

Figure 50. Manual Exposure Window

![Manual Exposure Window](image)

Each parameter can either be selected using the spin-buttons to the left or by moving the individual slider-controls.

2.6.12.1 Shutter Value:
The Shutter Value setting directly controls the exposure-time used by the camera. Please refer to Camera Operation Manual for corresponding exposure time.

2.6.12.2 Gain Value:
The Gain Value setting directly control the gain applied to images captured by the CCD-sensor. The signal-to-noise ratio will be increased by lowering the gain and thereby produce images with less noise.

2.6.12.3 VT[Top]/VT[Bottom] Values:
The VT[Top] and VT[Bottom] values control the reference voltages used during the digitization of the pixel values from the CCD-sensor. By controlling these two values it is possible to “optimize” the image capture to get the optimal full “digital resolution” for a certain range of the analog signal level.
2.6.13 Image Processing Window

In order to enhance the display of images on the PC-screen it is possible in ENSetup to change the Gamma Correction value (mid-tones) and/or the Brightness and Contrast of the images. This will not change the contents of the images captured on the PC but only change the visual appearance on the PC.

The context menu =>Image Processing opens a new window that displays the image processing tools. Using this Image Processing it is possible to adjust the Gamma-correction, Brightness, Contrast and Saturation on the displayed images. This will not change the images saved using ENSetup but the Image Processing can also be activated on the images printed out using the File=>Print...menu.

Figure 51. Image Processing Context Menu

2.6.14 Laser Setup Window

If a Laser Vehicle Detector is connected to the camera it will be possible to setup the laser settings using a Laser Vehicle Detector Settings window.
In the Property Grid control all values can be manually changed. It will initially contain the settings read directly from the laser. To transfer any new settings to the laser, simply press the Apply button.

The laser has got a built-in Laser Pointer LED that can be used for aligning the laser detector. It will be switched on when the check-mark is set. It will automatically be switched off when the Laser Vehicle Detector Settings window is closed.

The Laser Setup dialog will be used to setup the Laser Vehicle Detector connected to the camera. To analyze the current setting, press the Collect Data button. This will start a data collection and display the result in the graph. When a car triggers the laser then a new image will be collected by the camera and the data collection will be terminated automatically. The new image will be displayed in the preview area. If the camera and the PC are time-synchronized then a trigger-line will be displayed on the graph indicating the trigger position.
2.6.14.1 Laser Setup Wizard

The easiest way to configure a laser vehicle detector is to use the Laser Setup Wizard. This guides you through a series of steps that will help determine the correct setup values for the laser based on actual distance measurements.
Start the Wizard by pressing Next button.

Data collection will start automatically but needs to be stopped by the user by pressing the Stop button. The whole idea with the data collection is to sample enough data in order to calculate the average distance to the road. If the variation of the collected data is too big the data will be discarded and a new data collection needs to be started. This will be the case if a vehicle drives past the laser during the data collection period.

If the data collection is OK then the result of the measurements will be displayed. Press Next to continue.
It is now possible to specify two offset values directly. These offset values will be used to calculate the trigger ranges used by the laser. The offset values can also be estimated if the distance from the laser down to the ground is known and the normal bumper height can be determined. Then both offset values will be calculated by the Wizard.

Press Next after the offset values are determined.

Next specify the Filter Size used by the laser when it generates range measurements. The higher the value the smoother the range data will be. But on the other hand the higher the value the longer delay will be introduced (this will result in bigger variations in the trigger line - depending on the vehicle speed!)

Recommended values for the Filter Size are around 3-5.
Next specify the Hysteresis Count used by the laser. In order for the laser to generate the trigger it will require this amount of consecutive samples to be within trigger range. This will help the laser to filter out any noise for instance from raindrops.

Figure 59. Hysteresis Count

Next specify the Trigger Output Polarity used by the laser.
The results generated by the laser will be displayed. Press Next to finish the Wizard.

Click the OK button.
2.7 Error Log Window

The ERROR LOG window is activated from the EN CAMERA SETUP windows Tools menu.

The list has information’s from the cameras (or ENSetup). IP-Addresses, UTC-time and log-level are listed.

The Error Log will be updated all the time - even when it is not displayed. The contents of the Error Log will only include all the logged items from when ENSetup was started. All Error Log items will be saved to the PCs hard disk though.

Figure 62. Error Log Window

<table>
<thead>
<tr>
<th>Index</th>
<th>Time</th>
<th>Log Level</th>
<th>Camera Name</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2306-2005 11:20:47:221</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>11</td>
<td>2306-2005 11:20:39:334</td>
<td>0</td>
<td></td>
<td>Error Present, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>10</td>
<td>2306-2005 11:20:36:007</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>9</td>
<td>2306-2005 11:20:36:227</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>8</td>
<td>2306-2005 11:20:34:705</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>7</td>
<td>2306-2005 11:20:29:955</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>6</td>
<td>2306-2005 11:20:19:944</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>5</td>
<td>2306-2005 11:20:19:363</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>4</td>
<td>2306-2005 11:20:19:361</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>3</td>
<td>2306-2005 11:19:58:936</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>2</td>
<td>2306-2005 11:19:18:415</td>
<td>0</td>
<td></td>
<td>Error Closed, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>1</td>
<td>2306-2005 11:18:03:451</td>
<td>0</td>
<td></td>
<td>Error Present, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
<tr>
<td>0</td>
<td>2306-2005 11:16:21:549</td>
<td>0</td>
<td></td>
<td>Error Present, FTP Server Error, Unable to open the FTP link. Check Username, password or rights.</td>
</tr>
</tbody>
</table>

2.7.1.1 Context Menus

Right-clicking the mouse on the ERROR LOG WINDOW (see Figure 62) activates the context menu.
Figure 63. Close-up of an Error Log Context Menu

<table>
<thead>
<tr>
<th>Level</th>
<th>Camera Name</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>EN: API2 dll description: EN-camera interfaced EN_API2 dll version 1.1.05 Setup version: 1.1.15.24825 starting on</td>
</tr>
<tr>
<td></td>
<td>Clear</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Open Logfile</td>
<td></td>
</tr>
</tbody>
</table>

=> *Clear* clears the Error Log list.

=> *Open Logfile* opens the logfile using the default text editor in Windows.
3 Configuration

3.1 User administration
The User Administration menu is found in the EN CAMERA SETUP tools menu (see Figure 6 on page 4). This will open the User Administration Window.

Figure 64. User Administration Window

1. There are three user levels: Restricted user, Supervisor and Administrator
2. Only users on “Administrator” level can enter this dialog via the menu.
3. All users information’s are saved on the hard disk after being encrypted using 64-bit DES encryption.
4. The User Administration dialog can:
   • Add new users
   • Delete existing users (except Administrator)
   • Modify existing users password and user level

To add a new user, simply press the Add button. This will display a new Edit User Credentials Windows.

Figure 65. User Credentials Dialog

Type in a new User Name and Password and select the required User Level from the Drop-Down list.

To Delete an existing user, simply select the user from the list and press the Delete button.

To Edit an existing user, simply select the user from the list and press the Edit button.

3.2 Firmware update
It is possible to update the firmware inside the cameras via the context menu described in Section 2.5.4 on page 9.

One or more cameras can be updated simultaneously by selecting the cameras in the camera tree-view in the left side of the Camera Properties Window.

This will open the Firmware Update Windows seen in Figure 66.
To update the firmware, click on the Update Firmware button. This will open a file selection window where the firmware file can be selected.

The default file type selected is a “Firmware pack file” type (compressed zip-file) containing a set of all firmware files released together. If the “Firmware pack file” type is selected then all the firmware files will be automatically updated if necessary (based on the version information included in the files).

The firmware pack contains the following files:

1. **EN Application** The part of the camera software that handles the logic for the EN camera. This file has extension “.APP”
2. **OS Image** The Linux Operating System image. This file has extension “.OSI”
3. **FPGA Bit-file** FPGA firmware that handles the image capture and logic. This file has extension “.BIT”
4. **Library/Driver** Low Level Firmware used by the EN Application to communicate with the hardware. This file has extension “.DRV”
5. **Camera module** The Camera Module firmware. This file has extension “.PAT” for TS-9720, “.2030” for TS-2030 EN or TS-2076 EN, “.1327” for TS-1327EN, and “.4032” for TS-4032EN.
6. **Documentation** A revision history for the firmware is found in the file “ReadMe.txt”. The Lane Controller communication protocol is described in the “xxx_LC_to_EN_IDx.pdf” file.

Individual firmware file types are selected using the “Files of type:” drop-down list. This makes it possible to update single firmware part instead of the whole firmware package.
It is possible to force the firmware files to be updated regardless of the version information. This is done by checking the “Force update of firmware in cameras” option before starting the firmware update.

To automatically reboot the cameras after successful update, simply check the “Automatically reboot cameras” option before starting the firmware update.

WARNING: If incompatible firmware files are uploaded into the camera, the camera might not be able to start up after reboot! In order to avoid this problem only use the “Firmware pack file” option to update a complete set of released firmware files.

3.3 Configure Storage Memory

The internal image storage memory can be individually configured for each camera.

The different image types are placed inside separate queues and a fixed maximum image size is defined for each image type.

It is possible to configure the following parameters for each queue:

Max Image Size: Maximum number of bytes allocated to hold a single image of the selected type.

Max Images to Store: Queue depth for the selected type.

Overflow Action: Specify what happens when the number of images has been exceeded. The possible actions are: “Stop Acquiring” or “Overwrite Oldest”.

If the memory configuration has been changed then the Allocate Memory! button will be enabled.
4 Appendix A: PC Minimum Specifications

4.1 Software:
- Windows XP Service Pack 2
- Dot NET framework 2.0

4.2 Hardware:
- At least 1.8 GHz CPU speed (P4 3GHz stationary PC or Centrino 1.6GHz laptop)
- 512 MB RAM
- Preferable Gigabit LAN support
- Monitor resolution minimum 1024x768
- Monitor with high luminous intensity (if the monitor is to be used outdoor)
5 Appendix B: Resolving IP-address problems

When the automatic device discovery searches for cameras on the networks, there are two basic IP-address problems that can be detected by the ENSetup during Device Discovery:

1. **IP-address Collision**: One or more cameras have got the same IP-address on the LAN network. This will make it impossible to communicate with both cameras.

2. **Unreachable Camera**: One or more cameras are configured to be used on a different IP sub-net. The combination of IP-address and subnet-mask makes it impossible for the camera to communicate with the PC running ENSetup.

The ENSetup will detect the above two problems and the following window will be displayed before ENSetup can continue.

**Figure 70. IP Address Conflict Window**

<table>
<thead>
<tr>
<th>MAC Address</th>
<th>IP Address</th>
<th>Subnet Mask</th>
<th>Default Gateway</th>
<th>Problem description</th>
</tr>
</thead>
<tbody>
<tr>
<td>00:0C:2F:00:00:43</td>
<td>192.168.0.59</td>
<td>255.255.255.0</td>
<td>0.0.0.0</td>
<td>The Camera is unreachable on the network. The IP Address needs to...</td>
</tr>
</tbody>
</table>

The way to resolve these IP-address problems is to change the static IP-address of the camera(s) that is/are wrong. The IP-address has to be changed in the cameras to make the IP-addresses unique for all cameras. The cameras also need to be placed on the correct subnet or else the PC will not be able to communicate with the cameras.

To resolve the problems, select the camera to change and press the Set IP Address button. This will open a new window where the IP-address can be typed in.

**Figure 71. Set New IP Address Window**

**Tip** Double-click the camera in the list that you want to set a new IP address - this will automatically open the IP-address window!