JAI

eBUS SDK for RHEL/CentOS 7 - x86 - 64 bit

The table below contains links to download the installer files for the version of the eBUS SDK for JAI software which is compatible with Red Hat Enterprise Linux 7 and CentOS 7.There are three SDK downloads available:

> eBUS 6.2.8 for RHEL/CentOS 7
> eBUS 6.2.4 for RHEL/CentOS 7
> eBUS 6.1.4 for RHEL/CentOS 7

Pre-requisite for GUI-bsed sample code
In order to compile GUI-based samples for RHEL/CentOS7, Qt 5.9.2 is required.

You can run "sudo yum install qt-devel" to install it.

Installation Instructions
These releases of the eBUS SDK for JAI are only compatible with 64-bit RHEL/CentOS 7 on x86. No other versions of the distributions are supported.

To install the eBUS SDK on RHEL/CentOS 7:

1. Copy the eBUS SDK installation package to your computer

2. From the terminal, execute the following command:
rpm-i eBUS_SDK_JAI_RHEL-CentOS-7-x86_64-[version#]-[build#].rpm

3. From the terminal, execute the eBUSPlayerJAI script in /opt/jai/ebus_sdk/[platform name]/bin

Download LinkFile Size
eBUS_SDK_JAI_RHEL-CentOS-x86_64-6.2.8-5877.rpm7.5 MB
eBUS_SDK_JAI_RHEL-CentOS-x86_64-6.2.4-5552.rpm6 MB
eBUS_SDK_JAI_RHEL-CentOS-7-x86_64-6.1.4-5137.rpm6 MB

Documentation
The following documentation is available. (These are the same documents as found in the Windows downloads table).

DocumentationVersionLink
eBUS Player User Guide (PDF)6.2 - 4 March 2021download
Installation Instructions and Release Notes (PDF)December 2021download

Companion packages
Companion packages are available for these versions of RHEL/CentOS 7. These packages provide the ebPCAPRecorder utility, which is a tool for capturing packets that are transferred between GigE Vision compliant transmitters and your computer. They can be downloaded below:

Download LinkFile Size
eBUS_SDK_Companion_Package_6.2.8.5877_RHEL-CentOS-x86_64160 KB
eBUS_SDK_Companion_Package_6.2.4.5552_RHEL-CentOS-x86_64160 KB
eBUS_SDK_Companion_Package_6.1.4.5137_RHEL-CentOS-7-x86_64170 KB
You are using an outdated browser!

Update your browser to display this website correctly. Update my browser now

×